Blowing O-rings and Check Valves

Mike V

Member
So we have a little two-pumper that the guys like to use for surface cleaning large areas because of the volume. We have a contract with the City to do the parking garages and this little unit helps alot in the speed at which we can move.

The problem......one of the guys has been taking it out to do houses and has been running both machines but did not have the 8GPM tips, just the 4 gpm he uses with one of the other trailers.
I have replaced o-rings and check valves a few times recently and am curious if that is the problem? I am running two different unloaders and different pumps, which may be a problem but has not in the past.

Any thoughts on a remedy, could it be the Tips being used?

CheckValve.jpgpump1.jpgPump2.jpgConnection.jpg
 

bks0005

New member
use the correct tips and have pressure guages on both pumps at the unloaders so you know what the pressure is at each pump/unloader.
 

Mike V

Member
No idea, Russ thinks it is the water supply too. Trailers are all out running so I won't know until the weekend when I can look.
 

Kiloman

New member
That inlet looks like crap if i was guessing your sucking air in that big with that rigging you have on the inlet side.I bet if you fix the inlet and double plumb you will not have anymore problems.
 

Mike V

Member
Agreed Hal! It is double plumbed but we do need to eliminate the fittings.

Thanks Paul, your boy Bill told me the same thing yesterday when I was picking his brain about another pump.

Why would I need a new pump Scott Wash?
 
Top